UPDATE!! Arbeitskopie!!GWG-Abschreibung per Excel berechnen: Pool oder Sofortabschreibung - was bringt mehr?

Die Excel-Techniken

Bisher noch keine Bewertungen für diesen Artikel.

Die Excel-Techniken

Zum Schluss wollen wir Sie noch in die Excel-Formeln einweihen, die wir für den Abschreibungsrechner verwendet haben. Wenn Sie nur das Tool benötigen, können Sie sich diesen Teil natürlich sparen. Aber vielleicht haben Sie ja Lust, etwas über die Excel-Formeln und das Makro zu erfahren, die dabei unter der Haube stecken?

Die Excel-Formeln, die der Abschreibungsplaner verwendet

Das Herzstück des Abschreibungsplaners sind die Formeln, insbesondere in der Tabelle GWG-Abschreibungsvergleich. Die Formeln und deren Erläuterung finden Sie in der folgenden Tabelle.

Zelle

Formel

Beschreibung

F6

=12-E6+1

Die Spalte F enthält Nebenrechnungen zur Berechnung der anteiligen Abschreibung für das erste Abschreibungsjahr und ist ausgeblendet, um das Tabellenmodell übersichtlich zu halten.

G6

=WENN(C6<250,01;C6;C6/5)

Die Formel prüft, ob der Wert in C6 unter 250,01 Euro liegt. Ist das der Fall, wird der Wert aus C6 übernommen. Ansonsten wird der Betrag auf 5 Jahre umgelegt

H6

=WENN($C6<800,01;$C6;$C6/$D6/12*$F6)

Die Formel prüft, ob der Wert in C6 unter 800,01 Euro liegt. Ist das der Fall, wird der Wert aus C6 übernommen. Ansonsten wird der Wert aus C6 auf die Jahre der Nutzungsdauer umgelegt und anteilig für das Jahr berechnet.

I6

=+H6-G6

Die Formel ermittelt die Differenz zwischen Pool und Sofortabschreibung.

Alle Formeln können in die nachfolgenden Zellen kopiert werden. Die Spalte Gesamt enthält lediglich Summenformeln.

Zellen sperren

Damit die Formeln in einer fertigen Tabelle nicht versehentlich überschrieben werden, wurden alle Zellen, bis auf die Eingabezellen, gesperrt. Standardmäßig ist allen Zellen eines Arbeitsblattes der Status Gesperrt zugewiesen. Aus diesem Grund müssen alle Zellen, in denen Eingaben erlaubt sind, von dieser Sperre ausgenommen werden. Das erledigt man im Dialog Zellen formatieren im Register Schutz. Dort wird das Kontrollkästchen Gesperrt deaktiviert.

Ab der Version Excel 2007 findet man den Dialog Zellen formatieren im Register Start. Klicken Sie im Bereich Zahl auf den schräng nach unten weisenden Pfeil in der rechten unteren Ecke.

Das Sperren von Zellen ist nur im Zusammenhang mit dem Blattschutz wirksam. Diesen finden im Menü Überprüfen. Klicken Sie dort auf die Schaltfläche Blatt schützen

71421_gwg0006-jpg

Die Funktion "Gültigkeit"

Mit Hilfe der Funktion Datenüberprüfung (Gültigkeit in den älteren Excel Versionen) aus dem Register bzw. Menü Daten wird auf der Registerkarte Einstellungen verhindert, dass Wirtschaftsgüter mit einem Wert von mehr als 1.000 Euro netto im Tabellenmodell erfasst werden können.

Auf diese Weise ist gewährleistet, dass nur Zahlen in den Vergleich einbezogen werden, die in der Praxis zur Ermittlung der Vorteilhaftigkeit der Abschreibungsmöglichkeiten relevant sind.

gwg2018_abb_datenu-berpru-fung-jpg

Dialogfeld "Datenüberprüfung"

Excel-Meldung bei Eingabe ungültiger Werte

Für den Fall, dass Sie versuchen, Wirtschaftsgüter mit einem Wert von mehr als 1.000 Euro zu erfassen, erhalten Sie von Excel folgende Meldung:

71423_gwg0009-jpg

Das Makro

Mithilfe eines Makros können Sie Vorgänge automatisieren. Diese Technik kann dazu eingesetzt werden, andere Tabellen oder Arbeitsmappen anzuspringen oder wie in der Anwendung Zeilen einzufügen und dabei automatisch Formeln zu kopieren.

Das folgende Makro fügt automatisch weitere Berechnungszeilen in die Tabelle ein:

Sub ZeileEinfügen()
    ActiveSheet.Unprotect
    Columns("F:F").Select
    Selection.EntireColumn.Hidden = False
    Rows("32:32").Select
    Selection.Insert Shift:=xlDown
    Range("B31:J31").Select
    Selection.Copy
    Range("B32").Select
    ActiveSheet.Paste
    Range("B32").Select
    Application.CutCopyMode = False
    Selection.ClearContents
    Range("C32").Select
    Selection.ClearContents
    Range("d32").Select
    Selection.ClearContents
    Range("E32").Select
    Selection.ClearContents
    Range("B32:J32").Select
    Selection.Borders(xlDiagonalDown).LineStyle = xlNone
    Selection.Borders(xlDiagonalUp).LineStyle = xlNone
    With Selection.Borders(xlEdgeLeft)
        .LineStyle = xlContinuous
        .Weight = xlThin
        .ColorIndex = xlAutomatic
    End With
    With Selection.Borders(xlEdgeTop)
        .LineStyle = xlContinuous
        .Weight = xlHairline
        .ColorIndex = xlAutomatic
    End With
    With Selection.Borders(xlEdgeBottom)
        .LineStyle = xlContinuous
        .Weight = xlHairline
        .ColorIndex = xlAutomatic
    End With
    With Selection.Borders(xlEdgeRight)
        .LineStyle = xlContinuous
        .Weight = xlThin
        .ColorIndex = xlAutomatic
    End With
    Range("B32").Select
        Columns("F:F").Select
    Selection.EntireColumn.Hidden = True
    ActiveSheet.Protect
    Sheets("GWG-Abschreibungsvergleich").Select
    Range("B5").Select
End Sub