öffentlich
Redaktion Druckversion

Excel: Minimum abhängig von einer Bedingung ermitteln

MIN()-Funktion, Arrayformeln

4.76923
(26)
Beitrag bewerten
Ersten Kommentar schreiben
Stand: 12. Dezember 2011

Wie Sie die Excel-Funktion zur Ermittlung eines Minimums noch verbessern können, zeigt Ihnen das folgende Beispiel, bei dem die Nullwerte im geprüften Zellbereich ignoriert werden sollen.

Es ist in Excel sehr leicht, den kleinsten Wert aus einer Datenliste zu ermitteln. Dafür stellt Excel die Min()-Funktion bereit. In der folgenden Abbildung steht in $A$20 die Formel =MIN(A1:A19):

Bild vergrößernDie Min()-Funktion ermittelt den kleinsten Wert.

Allerdings stehen in dem untersuchten Bereich nicht nur echte 0-Werte, sondern auch noch leere Zellen, die ebenfalls den Wert 0 haben. Daher kommt diese Min()-Funktion zum wenig brauchbaren Ergebnis 0.

Wollen Sie hingegen ein Minimum abhängig von einer Bedingung (also beispielsweise nur die Werte größer als 0) ermitteln, müssen Sie ein wenig tiefer in die Excel-Trickkiste greifen. Geben Sie in einer beliebigen Zelle die folgende Formel ein, wenn der zu untersuchende Bereich weiterhin A1:A19 umfasst:

=MIN(WENN(A1:A19>0;A1:A19))

Allerdings dürfen Sie diese Formel nicht wie gewohnt mit der Eingabe-(Return-)Taste bestätigen, sondern müssen die Tastenkombination Strg+Umschalt+Eingabe (beziehungsweise Ctrl+Shift+Return) nutzen. Um die Formel herum zeigt Excel dann in der Eingabezeile geschweifte Klammern an:

{=MIN(WENN(A1:A19>0;A1:A19))}

Diese geschweiften Klammern dürfen Sie nicht eingeben! Sie sind lediglich ein Hinweis darauf, dass es sich hier um eine so genannte Arrayformel handelt, die mehrere Zellen gleichzeitig berechnen und das Ergebnis dann zusammenfassen kann.

Bild vergrößernDie Arrayformel ermittelt den zweitkleinsten Wert.

Besser arbeiten mit Bereichsnamen

Die lästige Eingabe konkreter Zelladressen kann mit Bereichsnamen deutlich verbessert werden. Vor allem lassen sich nachträgliche Anpassungen viel einfacher behalten. Markieren Sie dazu den Bereich A1:A19 und rufen Sie das Menü Einfügen/Namen/Definieren auf (in Excel 2007: Formeln/Definierte Namen/Namen definieren) und tragen Sie einen neuen Namen für diesen Bereich ein.

Geben Sie hier den Bereichsnamen an.

Sie können den Namen auch direkt im Namenfeld eingeben:

Bild vergrößern

Anschließend lautet die Formel {=MIN(WENN(meineDaten>0;meineDaten))}, wobei Sie die Bereichsnamen entweder direkt schreiben oder per F3-Taste aus einem Dialog auswählen können.

Weitere Tipps zur Nutzung solcher Bereichsnamen finden Sie im Beitrag "Professionelles Arbeiten dank Bereichsnamen".

Im nächsten Beispiel geht es darum, zu ermitteln, wie oft ein bestimmter Name in einer Liste vorkommt:

Bild vergrößernDie Arrayformel findet auch die Häufigkeit eines vorkommenden Namens.

Die Formel dazu lautet:

=SUMME(WENN(A1:A11="Hölscher";1;0))

Auch hier muss die Eingabe mit Strg+Umschalt+Eingabe bestätigt werden, sodass anschließend wieder die geschweiften Klammern erscheinen:

{=SUMME(WENN(A1:A11="Hölscher";1;0))}

Durch diese Technik sind Sie enorm flexibel, denn es lassen sich beliebige Bedingungen innerhalb der Wenn()-Funktion formulieren. Wichtig ist dabei nur, dass die äußere Funktion eine aggregierende, also zusammenfassende Fähigkeit besitzt. Das leisten typischerweise Summe, Min, Max, Mittelwert oder Anzahl.


Beitrag bewerten

Ihre Wertung:

 

Mitglied werden, Vorteile nutzen!

  • Sie können alles lesen und herunterladen: Beiträge, PDF-Dateien und Zusatzdateien (Checklisten, Vorlagen, Musterbriefe, Excel-Rechner u.v.a.m.)
  • Unsere Autoren beantworten Ihre Fragen

Downloads zu diesem Beitrag

Newsletter abonnieren